Comunidad Oracle Hispana

Hemos abierto esta discusion para todos aquellos que tengan dudas o inconvenientes con la instalacion de Oracle Database 11g Release 2 utillizando la versión completa del tutorial de instalación que Fernando J. Andrade puso a disposicion de toda la Comunidad.

Visitas: 5116

Responde a esto

Respuestas a esta discusión

hola que tal tengo una duda. yo no he particionado e disco para la instalaccion del grid pero ya e hecho la version 1 de la guia . mi consulta es si particiono ahora traerá algún error o necesariamente tengo que realizar todos los pasos desde el principio

 

 

Hola a todos.

Les cuento que tengo un problemilla, me quede sin espacio en la particion asignada para el curso en el host real, en medio de la instalacion de la base de datos con el asistente dbca. Luego de reacomadar discos en otras particiones, ejecuto nuevamente dbca y en el paso 3 "Database Identification" me dice: "The oracle system identifier (SID) "orcl" already exists. Specify another SID"

¿Alguien me puede decir como limpiar la anterior instalacion que quedo inconclusa/corrupta ?

El asistente dbca no habilita la opcion para eliminar la base de datos.

 

Gracias.

Buenas:

Tengo una pregunta sobre el orden de los discos.

Cuando hago la instalacion como indica el manual, el de 36 lo asigno a SCSI y el linux lo coloca en la  posicion "a", ya que el linux detecta como disco inicial el SCSI y despues los sata. 

Al terminar la instalacion, se retorna el disco de 36 a SATA (para que levante el linux ya que de otra forma no inicia el SO)  de tal forma que al hacer el cambio de 36 y llevarlo a SATA, el linux le asigna la etiqueta "E",
 y al momento de hacer el etiquetado

[root@curso ~]# fdisk /dev/sde

te indica que el disco es de 36GB y que contiene al SO.


SATA:
e: 36GB
f. 3GB
g. 3GB
h. 3GB
i. 3GB

SCSI
a. 3BG
b. 3GB
c. 3GB
d. 3GB


Ahora si indico al inicio que el de 36 sea SATA, en la instalacion me indica que el de 36GB esta en "e" , y al terminar la instalacion
tampoco inicia el linux, la pantalla se queda en negro como en el 1er caso.
Si lo llevo a SCSI, sigue sin iniciar.

Y el detalle radica en que: Siempre se detectan primero los discos SCSI y despues los SATA, adema es necesario que el disco de 36
este en SATA ya que en SCSI no inicia.

No se si hay alguna configuracion, para que reconosca los disco SATA como los primeros antes que los SCSI.


2. quitenme la duda, sobre la instalacion de la grid.

- DATA:  se le asignan los discos SCSI?
- Area de Recuperación de la Base (FRA): se le asignan los discos SATA?


Gracias.

@Gerard: no tienes que rehacer nada tienes que continuar desde la mitad del manual.

@Alejandro: todo depende si la instancia ASM se levanta, si puedes entrar al asmcmd y limpiar los datos de ORCL, luego puedes borrar la entrada en el /etc/oratab y puedes volver a crear la base. Primero validar si la instancia de ASM esta levantanda y si te puedes conectar 

oracle# ps -ef | grep pmon >> si sale pmon_+ASM esta arriba

si la base de datos oracle esta arriba hay que bajarla con el srvcrl o haciendo un shutdown abort.

entras al asmcmd y borras todo.

oracle# . oraenv  ( +ASM)

oracle# asmcmd

No hay una solución fácil para esto y esta lleno de dependes ( si se levanta el asm o no, si se levanta orcl o no).

 

@Juan.

La idea es que el disco se presente en la posición a /dev/sda, si ya se presenta así no ha porque cambiarlo. Por si darles los discos de SATA o de SCSI a los diskgroups da lo mismo, al final es transparente solo que tendras los DG con uno u otro grupo de discos a nivel físico (virtual).

 

Hola Fernando, ya habia realizado lo que comentaste, solo me habia quedado esa duda.

 

Entonces, lista la 2da parte y esperando la 3era

 

Gracias!

Saludos.

Gracias Fernando por la respuesta, la voy a archivar.

Lamentablemente mi anciedad me llevo a ejecutar esta mañana: $ORACLE_HOME/deinstall/deinstall .. algo que no volvere a hacer mas .... me borro todo el $ORACLE_HOME de la base de datos :( :(

ASM esta intacto, por lo que debere inciar de nuevo con la instalacion del soft de base de datos en adelante.

 

Sld2.

Fernando J. Andrade dice:

@Gerard: no tienes que rehacer nada tienes que continuar desde la mitad del manual.

@Alejandro: todo depende si la instancia ASM se levanta, si puedes entrar al asmcmd y limpiar los datos de ORCL, luego puedes borrar la entrada en el /etc/oratab y puedes volver a crear la base. Primero validar si la instancia de ASM esta levantanda y si te puedes conectar 

oracle# ps -ef | grep pmon >> si sale pmon_+ASM esta arriba

si la base de datos oracle esta arriba hay que bajarla con el srvcrl o haciendo un shutdown abort.

entras al asmcmd y borras todo.

oracle# . oraenv  ( +ASM)

oracle# asmcmd

No hay una solución fácil para esto y esta lleno de dependes ( si se levanta el asm o no, si se levanta orcl o no).

 

@Juan.

La idea es que el disco se presente en la posición a /dev/sda, si ya se presenta así no ha porque cambiarlo. Por si darles los discos de SATA o de SCSI a los diskgroups da lo mismo, al final es transparente solo que tendras los DG con uno u otro grupo de discos a nivel físico (virtual).

 

Ahhh por cierto ... excelente el instructivo, claro y entretenido.

Gracias por este aporte, tambien.

 

Sld2

Alejandro Andino dice:

Gracias Fernando por la respuesta, la voy a guardar.

Lamentablemente mi anciedad me llevo a ejecutar esta mañana: $ORACLE_HOME/deinstall/deinstall .. algo que no volvere a hacer mas .... me borro todo el $ORACLE_HOME de la base de datos :( :(

ASM esta intacto, por lo que debere inciar de nuevo con la instalacion del soft de base de datos en adelante.

 

Sld2.

Fernando J. Andrade dice:

@Gerard: no tienes que rehacer nada tienes que continuar desde la mitad del manual.

@Alejandro: todo depende si la instancia ASM se levanta, si puedes entrar al asmcmd y limpiar los datos de ORCL, luego puedes borrar la entrada en el /etc/oratab y puedes volver a crear la base. Primero validar si la instancia de ASM esta levantanda y si te puedes conectar 

oracle# ps -ef | grep pmon >> si sale pmon_+ASM esta arriba

si la base de datos oracle esta arriba hay que bajarla con el srvcrl o haciendo un shutdown abort.

entras al asmcmd y borras todo.

oracle# . oraenv  ( +ASM)

oracle# asmcmd

No hay una solución fácil para esto y esta lleno de dependes ( si se levanta el asm o no, si se levanta orcl o no).

 

@Juan.

La idea es que el disco se presente en la posición a /dev/sda, si ya se presenta así no ha porque cambiarlo. Por si darles los discos de SATA o de SCSI a los diskgroups da lo mismo, al final es transparente solo que tendras los DG con uno u otro grupo de discos a nivel físico (virtual).

 

HOLA FERNANDO

 

particione un nuevo disco para poder usar el ASM , como dice la guía 8 discos de 3 gb divididos en dos controladores SATA y SCSI  y en la SCSI esta el disco de mayor capacidad el de 36 gb .. bueno sigo con la guia y todo muy bien hasta llegar a la pagina 17 donde dice que nos pidira reiniciar ... bueno la cosa que al reiniciar se  queda plantada en una pantalla negra y no carga el sistema ,,,, ahora si pongo f12 al estar reiniciando me aparece esto

 

Detected hard disks:

 

AHCI controler:

1) primary master

2)primary slave
3)secondaty master

4)secondary slave

 

SCSI controller

5)hard disk

6)hard disk

7)hard disk

8)hard disk

 

other boot devuces

f floppy

c cdrom

i lan

 

 

b continue booting

 

bueno como podrás ver el disco de 36 gb no esta.. desapareció

y si intento entrar cualquiera se queda en la pantalla negra... pero si intento en la posición 5 donde esta dicho disco de 36 gb aparece el grub pero sin ningún sistema a escoger

 

que ha pasado algo hice mal?

seguí la guía sin error

desde ya gracias

 

Fernando J. Andrade dice:

@Gerard: no tienes que rehacer nada tienes que continuar desde la mitad del manual.

Archivos adjuntos:

Hola a Todos. 

Todo me iva de maravilla pero me da error al cargar el ASM.

Al hacer el configure me da error.

Default user to own the driver interface [oracle]:

Default group to own the driver interface [oinstall]:

Start Oracle ASM library driver on boot (y/n) [y]:

Scan for Oracle ASM disks on boot (y/n) [y]:

Writing Oracle ASM library driver configuration: done

Initializing the Oracle ASMLib driver:                     [FAILED]

 

he mirado el /var/log/oracleasm

Creating /dev/oracleasm mount point: /dev/oracleasm

Loading module "oracleasm": failed

Unable to load module "oracleasm"

Loading module "oracleasm": failed

Unable to load module "oracleasm"

 Creating /dev/oracleasm mount point: /dev/oracleasm

Loading module "oracleasm": failed

Unable to load module "oracleasm"

Loading module "oracleasm": failed

Unable to load module "oracleasm"                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                               1Ayuda  2Desple 3Salir  4Hex    5Línea  6BúsqRx 7Buscar 8Crudo  9SinFor 10Salir

 

He estado mirando y parece ser que puede ser que no haya instalado el modulo correcto de asm según el kernel pero me estraña. Os copio la información al respecto por si me podéis ayudar.

[root@curso log]# [root@curso log]# rpm -qa|grep oracleasm

oracleasm-support-2.1.4-1.el5

oracleasm-2.6.18-92.el5xen-2.0.4-1.el5

oracleasm-2.6.18-92.el5-2.0.4-1.el5

You have new mail in /var/spool/mail/root[root@curso log]# uname -r

2.6.18-238.el5

[root@curso log]# uname -a

Linux curso.coh 2.6.18-238.el5 #1 SMP Tue Jan 4 15:24:05 EST 2011 i686 athlon i386 GNU/Linux[root@curso log]#

A alguien le ha pasado algo similar???

Luis Antoli dice:

Hola a Todos. 

Todo me iva de maravilla pero me da error al cargar el ASM.

Al hacer el configure me da error.

Default user to own the driver interface [oracle]:

Default group to own the driver interface [oinstall]:

Start Oracle ASM library driver on boot (y/n) [y]:

Scan for Oracle ASM disks on boot (y/n) [y]:

Writing Oracle ASM library driver configuration: done

Initializing the Oracle ASMLib driver:                     [FAILED]

 

he mirado el /var/log/oracleasm

Creating /dev/oracleasm mount point: /dev/oracleasm

Loading module "oracleasm": failed

Unable to load module "oracleasm"

Loading module "oracleasm": failed

Unable to load module "oracleasm"

 Creating /dev/oracleasm mount point: /dev/oracleasm

Loading module "oracleasm": failed

Unable to load module "oracleasm"

Loading module "oracleasm": failed

Unable to load module "oracleasm"                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                               1Ayuda  2Desple 3Salir  4Hex    5Línea  6BúsqRx 7Buscar 8Crudo  9SinFor 10Salir

 

 

 

 

 

Voy probando cosas y las remito por si sirven de apollo a mi petición de auxilio ;)

He hecho un yum update y depués instalado de nuevo el oracleasm por si me actualizaba algún módulo del

sistema pero todo está igual

Lanzando esta instrucción me da como que el paquete de asm que tengo no es el adecuado al kernel que tengo instalado. Puede ser que sea ese el problema????

 

[root@curso ~]# rpm -q oracleasm-`uname -r`

el paquete oracleasm-2.6.18-238.el5 no está instalado

 

El kernel es:


uname -r

2.6.18-238.el5

 

 



Luis Antoli dice:

He estado mirando y parece ser que puede ser que no haya instalado el modulo correcto de asm según el kernel pero me estraña. Os copio la información al respecto por si me podéis ayudar.

[root@curso log]# [root@curso log]# rpm -qa|grep oracleasm

oracleasm-support-2.1.4-1.el5

oracleasm-2.6.18-92.el5xen-2.0.4-1.el5

oracleasm-2.6.18-92.el5-2.0.4-1.el5

You have new mail in /var/spool/mail/root[root@curso log]# uname -r

2.6.18-238.el5

[root@curso log]# uname -a

Linux curso.coh 2.6.18-238.el5 #1 SMP Tue Jan 4 15:24:05 EST 2011 i686 athlon i386 GNU/Linux[root@curso log]#

 

 

A alguien le ha pasado algo similar???

Luis Antoli dice:

Hola a Todos. 

Todo me iva de maravilla pero me da error al cargar el ASM.

Al hacer el configure me da error.

Default user to own the driver interface [oracle]:

Default group to own the driver interface [oinstall]:

Start Oracle ASM library driver on boot (y/n) [y]:

Scan for Oracle ASM disks on boot (y/n) [y]:

Writing Oracle ASM library driver configuration: done

Initializing the Oracle ASMLib driver:                     [FAILED]

 

he mirado el /var/log/oracleasm

Creating /dev/oracleasm mount point: /dev/oracleasm

Loading module "oracleasm": failed

Unable to load module "oracleasm"

Loading module "oracleasm": failed

Unable to load module "oracleasm"

 Creating /dev/oracleasm mount point: /dev/oracleasm

Loading module "oracleasm": failed

Unable to load module "oracleasm"

Loading module "oracleasm": failed

Unable to load module "oracleasm"                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                               1Ayuda  2Desple 3Salir  4Hex    5Línea  6BúsqRx 7Buscar 8Crudo  9SinFor 10Salir

 

 

 

 

 

Hey Luis A. has descargado actualizado el repo list de Yum con el de Oracle?

 

Si es asi, solo tienes que hacer un YUM INSTALL ORACLEASM y dejar que el mismo resuelva sus dependencias, lo he hecho asi y no me ha dado ningun problema.

 

ahora yo he tenido un problema diferente, mi problema viene cuando realizo los scripts finales para terminar de instalar el Grid, en el segundo script, me da un error del comando de crtss o algo asi!, me da un segmentation fault el comando y no se ejecuta, por lo que no se crea la maquina como un nodo!

Responder a debate

RSS

© 2017   Creado por Fernando Garcia.   Tecnología de

Insignias  |  Informar un problema  |  Términos de servicio